Meter Read/Alert Processing Delayed

Incident Report for Print Tracker Pro Status

Resolved

The meter read and alert processing system is now fully up to date, and all delays have been resolved. Alerts are being delivered normally. Thank you for your patience.
Posted Mar 26, 2025 - 07:43 MDT

Monitoring

Our meter read and alert processing system is currently experiencing delays. We’re actively monitoring the situation, and the system is expected to catch up shortly. You may notice alerts arriving later than usual. We appreciate your patience.
Posted Mar 26, 2025 - 07:07 MDT
This incident affected: DCA Server.